Cloudlinux 8 kernel update error: current running kernel is NOT supported
Incident Report for CloudLinux
Resolved
The fix was provided in the latest kernel-4.18.0-425.3.1.lve.3.el8
No more issues registered.
This incident has been resolved.
Posted Jan 18, 2023 - 19:12 UTC
Update
The problem was localized, and the situation stabilized.
We continue to monitor the progress of the rollout and wait for the closure of all tasks related.
Posted Jan 10, 2023 - 19:57 UTC
Update
The fix is now available in our rollout repo, to install it immediately please feel free to run:
yum update kernel kmod-lve --enablerepo=cloudlinux-rollout-10-bypass
Posted Jan 05, 2023 - 18:23 UTC
Update
CL Developers released a fix to the beta repository, to install it please run the following command:
# yum update kernel kmod --enablerepo=cloudlinux-updates-testing
Posted Jan 04, 2023 - 12:15 UTC
Update
We are continuing to monitor for any further issues.
Posted Jan 04, 2023 - 12:13 UTC
Monitoring
The issue appeared after the latest CL8 kernel update.
The kernels are: 4.18.0-425.3.1.lve.1.el8.x86_64 or 4.18.0-425.3.1.lve.2.el8.x86_64
The kmod-lve package is kmod-lve-2.0-48.el8.x86_64

The kernel can't be loaded manually - modprobe kmodlve errors out:
modprobe: FATAL: Module kmodlve not found in directory /lib/modules/4.18.0-425.3.1.lve.1.el8.x86_64
modprobe: ERROR: could not insert 'kmodlve': Invalid argument

If the above match, the following commands should help:
# yum reinstall kmod-lve-2.0-48.el8.x86_64
# modprobe kmodlve

Also, the following services may need to be restarted:
# systemctl restart cagefs
# systemctl restart lve*
Posted Dec 30, 2022 - 15:57 UTC
This incident affected: CloudLinux OS Components (CloudLinux Kernel).