Planned Maintenance!

Incident Report for CloudLinux

Resolved

We have successfully completed the planned maintenance on our public repository infrastructure.
There was no significant impact reported during the maintenance period.
All systems are now operating normally.
Posted Dec 10, 2024 - 20:32 UTC

Update

Additional maintenance event:

To ensure the continued reliability of our services, we are performing planned maintenance on our public repository infrastructure from Wednesday 2024-11-27 19:00 UTC to Thursday 2024-11-28 09:00 UTC . This work will involve temporarily moving the affected services to a backup infrastructure to mitigate downtime.

Potential Impact:

Some repository services may experience brief periods of unavailability during the switch.

Repos Involved:
repo.cloudlinux.com (including ELS: centos 6, oraclelinux 6, ubuntu16, centos 8, PHP ELS)
errata.cloudlinux.com
rollout.cloudlinux.com
els-rollout.cloudlinux.com
repo.imunify360.com
repo.imunify360.cloudlinux.com
download.imunify360.com
repo.alt.cloudlinux.com

The Maintenance Plan:

November 27, 19:00 UTC: Services will transition to the backup infrastructure.
November 28 09:00 UTC: Services will be switched back to the primary infrastructure.

Thank you for your patience as we work to enhance the reliability of our infrastructure.
Posted Nov 27, 2024 - 16:15 UTC

Investigating

We would like to inform you about upcoming maintenance that may cause temporary service degradation or limited functionality.

Below is the schedule:
Start: 2024-11-25, 03:30 AM UTC
End: 2024-11-25, 04:30 AM UTC

Start: 2024-11-26, 02:30 AM UTC
End: 2024-11-26, 03:30 AM UTC

Start: 2024-11-26, 03:30 AM UTC
End: 2024-11-26, 04:30 AM UTC

Start: 2024-11-27, 02:30 AM UTC
End: 2024-11-27, 03:30 AM UTC

Start: 2024-11-27, 03:30 AM UTC
End: 2024-11-27, 04:30 AM UTC

Start: 2024-11-28, 02:30 AM UTC
End: 2024-11-28, 03:30 AM UTC

Start: 2024-11-28, 03:30 AM UTC
End: 2024-11-28, 04:30 AM UTC

Start: 2024-12-03, 03:30 AM UTC
End: 2024-12-03, 05:30 AM UTC

Start: 2024-12-04, 03:30 AM UTC
End: 2024-12-04, 05:30 AM UTC

Start: 2024-12-05, 03:30 AM UTC
End: 2024-12-05, 05:30 AM UTC

Start: 2024-12-06, 03:30 AM UTC
End: 2024-12-06, 05:30 AM UTC

During the maintenance window, some of our services will be temporarily unavailable - specifically, we expect the following services to be limited or experience reduced performance during the specified time:

- Cloud-assisted malware scanning: Degraded performance
- PHP Auto-Immunity: Degraded performance
- Global and RBL IP lists updates: Possible service suspension
- DashboardPRO, Centralized Management UI, and Imunify Agent UI Dashboard: No fresh data and potential data loss
- SmartAdvice: Limited functionality (unable to provide optimization advice) and outdated data on CL Manager Dashboard (loss of data during the maintenance period)
- PHP X-Ray: Possible service suspension.


**Additional Impact for December 4–5 Maintenance**
During the December maintenance window, we also expect disruptions to the following services:
- Diagnostics tools (cldoctor, KC doctor): Limited or unavailable functionality
- Web-based forms for providing SSH access details: Possible interruptions


We apologize for any inconvenience this may cause and appreciate your understanding!
Posted Nov 24, 2024 - 13:58 UTC
This incident affected: CloudLinux Network.