Issue with the deploy script: Curl error (58): Problem with the local SSL certificate

Incident Report for CloudLinux

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 13:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2025 - 13:29 UTC

Investigating

The cldeploy CloudLinux conversion script fails due to a dependency conflict between rhn-client-tools and cloudlinux-ea4-release-1-8.el8.noarch, preventing the installation of rhn-setup and therefore the conversion to CloudLinux.

A workaround found is to install the rhn packages manually before running the cldeploy script

# dnf list available rhn-client-tools --showduplicates
...
Available Packages
rhn-client-tools.x86_64 2.8.16-13.module_el8.3.0+2053+3ddf2832 appstream
rhn-client-tools.x86_64 1:2.11.2-1.module_el8.9.0+6803+3ddf2832.cloudlinux repo.cloudlinux.com_cloudlinux_8_BaseOS_x86_64_os_
rhn-client-tools.x86_64 1:2.12.4-1.module_el8.10.0+6904+f35044bf.cloudlinux repo.cloudlinux.com_cloudlinux_8_BaseOS_x86_64_os_
...

# dnf install rhn-client-tools-1:2.12.4-1.module_el8.10.0+6904+f35044bf.cloudlinux.x86_64

# dnf install rhn-setup
Posted Mar 25, 2025 - 19:20 UTC
This incident affected: CloudLinux Network.