libmysqlclient.so.18.0.0 conflicts with file from package mysqlclient18-compat
Incident Report for CloudLinux
Resolved
The packages with the fix have been released.
The incident has been resolved.
Posted Oct 09, 2023 - 13:11 UTC
Investigating
The following error appears when running yum update:
Error: Transaction test error:
file /usr/lib64/mysql/libmysqlclient.so.18.0.0 from install of cl-MariaDB103-libs-10.3.39-3.module_el8.8.0+6682+4c6417b1.cloudlinux.x86_64 conflicts with file from package mysqlclient18-compat-10.1.28-2.el8.cloudlinux.x86_64

As a workaround, we currently just suggest removing the conflicting package:
yum remove mysqlclient18-compat

and then running:
yum clean all

The internal task has been submitted (CLOS-1828), and developers are investigating the issue.
Posted Jul 18, 2023 - 14:40 UTC
This incident affected: CloudLinux OS Components (MySQL Governor).