421 Misdirected Request Error After Recent ea-apache Update

Incident Report for CloudLinux

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 11:15 UTC

Monitoring

The fix has been released to our beta repo.

To install, please run
yum update ea-apache24* ea-nginx --enablerepo=cl-ea4-testing
Posted Jul 26, 2025 - 13:19 UTC

Investigating

After upgrading to ea-apache24-2.4.64, websites running behind EA-Nginx (or other reverse proxies like Cloudflare) on cPanel servers may start displaying the error:

421 Misdirected Request


Workaround:

1- Downgrade Apache to 2.4.63:
# yum downgrade ea-apache24*

2- Lock Apache version to prevent automatic updates until a fix is released:
# yum versionlock add ea-apache24*

* Make sure that you have yum-plugin-versionlock installed.

For CL 7
# yum install yum-plugin-versionlock

For CL 8/9
# yum install python3-dnf-plugin-versionlock
Posted Jul 26, 2025 - 00:53 UTC
This incident affected: CloudLinux OS Components (EasyApache4 PHP packages).