rpm dependencies issue on cPanel servers: ea-php74-cli and ea-openssl11
Incident Report for Cloud Linux Inc
Resolved
This incident has been resolved.
Posted Feb 27, 2021 - 13:25 UTC
Monitoring
The fix for the issue has been released to the stable repository.
If you are facing this problem, please clean all yum cache with the following command:
yum clean all
And retry the installation.
Posted Feb 26, 2021 - 18:00 UTC
Identified
During the installation or update of the ea-php74 or fresh conversion cPanel server to CloudLinux the following collision between packages may occur:

Error: Package: 1:ea-php74-php-cli-7.4.15-1.el7.cloudlinux.x86_64 (cl-ea4)
Requires: ea-openssl11 = 1:1.1.1h

The deployment of the solution for this issue is scheduled for Monday and can be tracked via task ID: EA4D-261.
Until there, please apply the workaround for this issue.

The workaround for this issue is to lock the version for the ea-openssl11 packages. It may be done with the following steps:

1) Install the versionlock plugin:
https://access.redhat.com/solutions/98873
yum install yum-plugin-versionlock

2) Lock max version for ea-openssl11 and ea-openssl11-devel packges:
yum versionlock ea-openssl11-devel-1.1.1h-1.el7.cloudlinux.x86_64
yum versionlock ea-openssl11-1.1.1h-1.el7.cloudlinux.x86_64

3) Check that yum installation of ea-php74 is working correctly.

Note: If you face this issue during the conversion process, after applying the workaround, please re-launch the cldeploy script to make sure, that all packages are installed correctly.
The --skip-registration key for cldeploy script is required to avoid license activation collision:
For a key-based license:
sh cldeploy -k --skip-registration
For an IP-based license:
sh cldeploy -i --skip-registration
Posted Feb 26, 2021 - 17:23 UTC
This incident affected: CloudLinux OS Components (EasyApache4 PHP packages).