System hangs at shutdown in blk_mq_freeze_queue_wait()
Incident Report for CloudLinux
Resolved
This incident has been resolved.
Posted Oct 02, 2024 - 15:42 UTC
Monitoring
Fixed package "tuned-profiles-cloudlinux-0.2-10" was released into the "cloudlinux-updates-testing" repo. It can be updated as follows:

# yum update tuned-profiles-cloudlinux --enablerepo=cloudlinux-updates-testing

We are currently monitoring the results
Posted Sep 27, 2024 - 04:35 UTC
Investigating
Our new tuned-profiles-cloudlinux 0.2-9 for CL8/CL9 disables Writeback Throttling. It presumably triggers the following issue:
System hangs at shutdown in blk_mq_freeze_queue_wait() when using kernel modules that are incorrectly working with internal blk-mq stuff.

The distribution of the tuned-profiles-cloudlinux 0.2-9 package has been stopped until the problem is resolved.
Posted Sep 18, 2024 - 16:23 UTC