ALT-PHP 8.2 without mysqli support
Incident Report for CloudLinux
Resolved
The fix was provided in the latest alt-php82-8.2.1-1
No more issues registered.
This incident has been resolved.
Posted Jan 24, 2023 - 18:52 UTC
Identified
Since official support for the mysqli extension has been discontinued by PHP:
https://php.watch/versions/8.2/mysqli-libmysql-no-longer-supported

We recommend that you do not use ALT-PHP8.2 while our developers are working on fixing the lack of support for the mysqli extension. If you encounter a similar problem and cannot give up using the alt-php82 version, then you can use the mysqlnd, nd_mysql, nd_mysqli, nd_pdo_mysql extension set.
Posted Jan 17, 2023 - 16:20 UTC
Investigating
Since PHP 8.2 MySQLi can no longer be compiled with libmysqli so ALT-PHP 8.2 does not have a corresponding extension too. But in PHP Selector it is still possible to select mysqli extension, this leads to errors due to missing extension file:

PHP Warning: PHP Startup: Unable to load dynamic library 'pdo_mysql.so' (tried: /opt/alt/php82/usr/lib64/php/modules/pdo_mysql.so (/opt/alt/php82/usr/lib64/php/modules/pdo_mysql.so: cannot open shared object file: No such file or directory), /opt/alt/php82/usr/lib64/php/modules/pdo_mysql.so.so (/opt/alt/php82/usr/lib64/php/modules/pdo_mysql.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

Also, due to the same reason, you may see such errors during the installation of alt-php82 packages:

ERROR : mysqli.so is not found. Please install alt-php82-mysql5.7 package
ERROR : mysqli.so is not found. Please install alt-php82-mysql5.7 package
ERROR : mysqli.so is not found. Please install alt-php82-mysql5.5 package
ERROR : mysqli.so is not found. Please install alt-php82-mysql5.1 package
ERROR : mysqli.so is not found. Please install alt-php82-mysql5.0 package
ERROR : alt-php82 reconfiguration is failed
Posted Jan 12, 2023 - 19:53 UTC
This incident affected: CloudLinux OS Components (Alt-PHP, PHP Selector).