Bug in MySQL 8.0.38 results in segfaults
Incident Report for CloudLinux
Resolved
The incident has been resolved, MySQL 8.0.39 successfully released into the stable.
Posted Aug 07, 2024 - 08:58 UTC
Update
Update 26/07/2024:
MySQL 8.0.39 is released at 23/07/2024. According to its Release Notes - https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-39.html
it contains a fix for the MySQL 8.0.38 critical issue about creation of large number of tables:

InnoDB: In some cases, following the creation of a very large number of tables (8001 or more), the server could not be restarted successfully. (Bug #36808732)
References: This issue is a regression of: Bug #33398681.

Our tests confirmed that the issue is fixed. So we have released cl-MySQL80-8.0.39-1 into the beta at 25/07/2024. We are going to start its gradual rollout on Monday, 29/07/2024
Posted Jul 26, 2024 - 12:20 UTC
Identified
After upgrade MуSQL server to 8.0.38 due to upstream bug, if you create a large number of tables, like 10000, the MySQL daemon will crash at restart.
To mitigate the issue, gradual rollout of the rollout slot-6 for the package cl-MySQL80@8.0.38-1 was paused

For additional information, you may refer to https://blog.cloudlinux.com/gradual-rollout-of-the-rollout-slot-6-for-the-package-cl-mysql808.0.38-1-was-paused
Posted Jul 17, 2024 - 10:23 UTC
This incident affected: CloudLinux OS Components (MySQL Governor).