yum update error Error: GPG check FAILED
Incident Report for CloudLinux
Resolved
This incident has been resolved.
Posted Feb 07, 2024 - 18:10 UTC
Monitoring
Another internal solution has been implemented so that CL8 customers who receive updates using regular CloudLinux mirrors no longer need to apply the workaround and can receive updates as usual.
Posted Jan 19, 2024 - 13:53 UTC
Identified
The GPG key for the xfsdump package was not installed, resulting in a GPG check failure during the package installation, which was resolved by importing the necessary key from the AlmaLinux repository.

Only CloudLinux OS 8 systems are affected

Please use one of the workarounds to resolve the issue:
Workaround #1
Execute the command:
rpm --import https://repo.almalinux.org/almalinux/RPM-GPG-KEY-AlmaLinux

Workaround #2
Execute the commands:
dnf clean all
dnf update -y --nogpgcheck

cloudlinux-release-8.9-2.el8 package contains an updated AlmaLinux key, but won't help with current systems. So please apply the workaround anyway.
Posted Jan 17, 2024 - 16:01 UTC