cPanel\yum update removing packages (alt-php, cagefs, etc)
Incident Report for CloudLinux
Resolved
We have not recieved new reports for 24 hours, we consider the case as resolved.
Posted Oct 27, 2022 - 08:49 UTC
Update
The issue was fixed from our side.
But we are still waiting for cPanel confirmation and monitor the situation.
cPanel task ID: CPANEL-41773.
Posted Oct 26, 2022 - 15:22 UTC
Monitoring
The problem is caused by some of almalinux mirrors (used as base-os repository) being out-of-sync. cPanel is using --allowerasing dnf option by-default during updates, if on your mirror you had the latests rpm-build package not available, then '--allowerasing' allowed erasing rpm-build package, which with 'clean_requirements_on_remove=True' lead to removal of dependencies. We currently unable to reproduce the problem, all mirrors should be already in-sync, out-of-sync mirrors are automatically removed from the mirror list.
Posted Oct 26, 2022 - 09:47 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 26, 2022 - 09:18 UTC
Investigating
cPanel nightly updates calling yum updates, which might cause removing important packages as alt-php,cagefs, lvemanager to be removed as dependency on affected systems.
If you are not affected yet - it's better to stop updates temporary.
Posted Oct 26, 2022 - 08:00 UTC