Conflicts during the upgrade of ALT-PHP81 packages.

Incident Report for CloudLinux

Resolved

This incident has been resolved.
Posted Oct 15, 2024 - 21:52 UTC

Monitoring

The packages have been released to slot 12 of the rollout repository and can be updated using a command such as:

yum update --enablerepo=cloudlinux-rollout-12-bypass
Posted Oct 09, 2024 - 13:25 UTC

Investigating

The following errors are found while updating the ALT-PHP81 packages:

Error:
Problem 1: package alt-php81-mysql5.5-8.1.29-1.el8.x86_64 from @System requires alt-php81-pdo = 8.1.29, but none of the providers can be installed
- cannot install both alt-php81-pdo-8.1.30-1.el8.x86_64 from cloudlinux-rollout-12 and alt-php81-pdo-8.1.29-2.el8.x86_64 from @System
- cannot install both alt-php81-pdo-8.1.30-1.el8.x86_64 from cloudlinux-rollout-12 and alt-php81-pdo-8.1.29-1.el8.x86_64 from cloudlinux-x86_64-server-8
- cannot install both alt-php81-pdo-8.1.30-1.el8.x86_64 from cloudlinux-rollout-12 and alt-php81-pdo-8.1.29-2.el8.x86_64 from cloudlinux-x86_64-server-8
- cannot install the best update candidate for package alt-php81-pdo-8.1.29-2.el8.x86_64


The recommended workaround is to exclude alt-php81 from updates:
yum update --exclude=alt-php81*

We're actively investigating the issue.
Posted Oct 08, 2024 - 12:12 UTC
This incident affected: CloudLinux OS Components (Alt-PHP).