ERROR anon_vma num_children for anon_vma
Incident Report for CloudLinux
Resolved
No new reports up to this moment, we consider the case closed.
Posted May 15, 2023 - 18:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 09, 2023 - 19:29 UTC
Identified
If your server is affected, you can mitigate the problem by running the following command:
# kcarectl --unload; kcarectl --update

In case of any doubt, please contact the CloudLinux Support team.
Posted May 04, 2023 - 08:59 UTC
Investigating
After applying the KernelCare patches K20230502_01 and K20230502_02 on servers with CloudLinux OS 7, the following types of errors are observed:
May 3 06:03:12 server kernel: ERROR anon_vma num_children for anon_vma ffff8c4ef0723a50 2 > 1
May 3 06:03:12 server kernel: ERROR anon_vma num_children for anon_vma ffff8c4ef0723a50 2 > 1
May 3 06:03:13 server kernel: ERROR anon_vma num_children for anon_vma ffff8c4ef0723a50 2 > 1
May 3 06:03:13 server kernel: ERROR anon_vma num_children for anon_vma ffff8c4ef0723a50 2 > 1

and:
May 3 05:45:54 server ccs_init: sh: fork: Cannot allocate memory
May 3 05:45:54 server ccs_init: sh: fork: Cannot allocate memory
May 3 05:45:54 server ccs_init: sh: fork: Cannot allocate memory

Servers start killing random processes with oom-killer, and respond with errors to random commands
/bin/sh: fork: Cannot allocate memory


! Deployment of the patches is stopped and they are no longer available. The problem is under investigation
Posted May 03, 2023 - 13:03 UTC
This incident affected: CloudLinux OS Components (CloudLinux Kernel).